Okay
  Public Ticket #464608
Flavor Woocommerce Permalink Problem
Closed

Comments

  • Daniel started the conversation

    I'm having trouble with getting Woocommerce (Version 2.3.11) to work with the Flavor Theme (Version: 1.13).

    On the Shop page: http://nfglive.com/shop/ the products appear however clicking them takes you to an incorrect link. For Example: http://nfglive.com/the-witcher-adventure-game/ This is the same URL that is shown in Edit Product.

    This page serves up a 404 Error - Page Not Found

    According to my Permalink settings, the correct url for the product should be /shop/product-name/ so if we manually enter: http://nfglive.com/shop/the-witcher-adventure-game/ we see the product page.

    From the Product page, if we click the category 'Board Games' it takes us to: http://nfglive.com/type-category/board-games/ where we see there are no products in that category.

    I believe I have narrowed it down to something to do with the Flavor theme as if I install a Woocommerce free theme 'Storefront' and activate it we see these link issues resolved.

    As seen in the attachment 'Edit Product Storefront Theme.jpg' the URL is updated and works correctly. The products appear in the appropriate category pages and the links on page seem to work as intended.

    Of course, if possible I would prefer to resolve this issue and continue using Flavor as it is an excellent Theme.

    Please let me know if there is any more information I can provide to help resolve this issue.

    -Dan

  •  321
    Brian replied

    Have you rebuilt your permalinks yet by clicking Save on the permalinks page? If so and its still not working, it could be an issue with the version of WooCommerce. Have you tested it with WooCommerce 2.0 yet? That\'s the latest version officially supported by the theme according to the theme item description at ThemeForest...

  • Daniel replied

    Uninstalled WooCommerce 2.3.11 and installed 2.0.20 from https://wordpress.org/plugins/woocommerce/developers/ and whilst it fixed the issue of no products being visible in the appropriate category page, the links to those products were still incorrect.

    I have rebuilt my permalink by clicking save on the permalinks page and tried different types of permalinks with no effect.

  •  321
    Brian replied

    Try with all other plugins completely disabled to rule out any plugin conflicts. I can\'t replicate this on my live demo...