Okay
  Public Ticket #286133
Wordpress 4.0 update = woocommerce error
Closed

Comments

  • Wayne started the conversation

    Hi there, i not long updated to Wordpress 4.0 but once i did, i have the follow error show up at the top of home page:

    Warning: Invalid argument supplied for foreach() in /home/geekstec/public_html/wp-content/plugins/woocommerce/includes/class-wc-webhook.php on line 87

    I'm not sure if this is a error with the theme or the plugin, but i did check for an update of the plugin after i had the error and i found they had an update out, but the problem is still there after i updated the plugin.

    Anyway i thought i would report so you can patch the theme, if needed. In the mean time i have turned off the plugin as i don't want that error showing up to all my visitors.

  •  321
    Brian replied

    What version of woocommerce are you running? Is it a version supported by the theme officially?

  •   Wayne replied privately
  •  321
    Brian replied

    That's 2.0+, not 2.2+, meaning anything within the 2.0 release (2.0.0, 2.0.1, 2.0.2, etc.) Sorry for the confusion. I haven't tested with 2.2.4 yet. 

    Just out of curiosity, have you tried it with only woocommerce active and no other plugins whatsoever? Also, have you tried it with woocommerce 2.0 and wordpress 4.0? Trying to isolate the issue...

  • Wayne replied

    OIC, my bad, hahaha. I just tested it out and i found it was woocommerce 2.2.4 that is the problem and not wordpress 4.0 (well i think). I removed woocommerce 2.2.4 and installed 2.1.12 and it worked on wordpress 4.0.

    So it looks like the latest version of woocommerce is not supported. Maybe it be an easy fix for you, for a future update. In the mean time i just keep 2.1.12 installed and use that :)

    Thanks for the help buddy.

  •  321
    Brian replied

    Thanks, I really appreciate this information. It will definitely assist me when I go to update the theme.