Okay
  Public Ticket #209480
saved changes
Closed

Comments

  • Maximiliano started the conversation

    hi there,

    i have some issue on my site.

    I made some change in my 12 mini site, it was ok until number 9 mini site, i mean i make my changes then i click on save.

    But at mini site number 10 I made some changes and at the end i click on save button, but nothing happened ..??? 

    why ???

  • Maximiliano replied

    hi there i have this error too ... what is????

  • Maximiliano replied

    this is incredible …!!! this is the third fresh wp and theme installation !!!!!! no plugin installed …. I am myself stew â€¦ it's incredible.

  • Kinshuk replied

    You haven't installed wordpress correctly. Those files that are not found, are Wordpress files and not the theme files. So, please install Wordpress correctly or I can do it for you.

  • Maximiliano replied

    hi there. i'm very sorry but this problem happend later install … I mean i have installed WP then theme … then i put some option right for my site in admin area then i create about 12 mini site and then i started to modify this mini site without a problem …. and at mini site number 10 i selected my option then i click on save … that's is … i have that error….

    So i reload the page i tried again … then nothing … i tried to delete the last 3 mini site … then i created again … but nothing the system can save all changes !!!!

    so i think that is there are some WP installation problem this problem will from the start …. wp 3.9 flavour 1.11

    in the second install my customer want to have a submenu … so i started to create a taxonomy …. ohhohh never maid … so i delete all and i have made a new fresh install.

    i made 3 different installation in my server … 

    suggestion...

  •  321
    Brian replied

    It's actually probably because of the max_input_vars server variable being hit. See requirement #5 here for solution: http://industrialthemes.ticksy.com/faq/1917

  • Maximiliano replied

    so i red your faq …

    Answer

    1. PHP 5.0+
    2. WordPress 3.8+
    3. cURL must be enabled on your web server (http://stackoverflow.com/questions/1347146/how-to-enable-curl-in-php-xampp)
    4. If you are using the social counts widget, file_get_contents() requires that you have allow_url_fopen turned on (http://www.php.net/manual/en/filesystem.configuration.php#ini.allow-url-fopen)
    5. If you have PHP version 5.3.9+ and you have more than 1,000 options posted in your theme options (this will rarely ever happen) you need to increase your max_input_vars setting on your web server (http://stackoverflow.com/questions/10303714/php-max-input-vars)

    I think that my problem is about number 5 … my site now if fresh install nothing installed…

    in my go daddy account i have php 5.4.23 and MySQL 5.5.32-cll-lve so let me know how can solve the problem â€¦. which file must be modify .. so i hope i can solve the issue … :(

  •  321
    Brian replied

    Contact your web host and ask them to increase that server setting for you - they can do it.

  • Maximiliano replied

    ok thanks … but can you tell me exactly what i must ask to him? please, thanks

  • Kinshuk replied

    Ask them this:

    Hello sir,

    I want to increase max_input_vars for my server. So, please do it for me.

    Thanks.

    Regards,

    Max

  •  321
    Brian replied

    ask them to increase the max_input_vars variable to 5,000

  • Maximiliano replied

    ok great thanks.

  • Maximiliano replied

    i speak with godaddy support they said that i can change the file .user.ini (said that is the same) but really i don't know where is this file on my server …. :(

    suggestions?

  •  321
    Brian replied

    If you need help with this sort of thing you should check out WordPress support or Stack Overflow since it's a question of server settings rather than a theme-specific question. I don't know how to change that for your server - all servers are different. I'm surprised godaddy didn't change that for you.

  • Maximiliano replied

    they send to me a faq link … i red it but on my server i don't found that file, on monday i call back godaddy. then we'll see ..

    :)

  •  321
    Brian replied

    Thanks, let me know if I can be of further assistance.

  • Maximiliano replied

    hi there, go daddy create in my public_html server a file .user.ini but i can't find max_var_max_input_vars  can u help me? i can give you an ftp account please my work now is stopped 

    :(

    thanks

  •  321
    Brian replied

    This is not theme-related but rather web server troubleshooting. If you do not know how to do this and your web host will not help you, you will need to try a site such as Stack Overflow or similar. I am not an expert in web servers and am only able to help with theme-related issues. I understand this is affecting theme functionality, but it is not caused by the theme itself and needs to be addressed on your web server.

    FYI the variable you're looking for is max_input_vars, not max_var_max_input_vars

  • Maximiliano replied

    hi there … i'll send u a script with go daddy support:

    • Jason
      what do you mean by microsites

      1:14:12 PM

    • Jason
      and what has been added to the .user.ini

      1:14:19 PM

    • Ferdinando
      every tab points not to a page, but to a small new site

      1:15:19 PM

    • Jason
      ok, what domain are they on, the primary domain that you listed is a default cpanel landing page

      1:15:36 PM

    • Ferdinando
      andcomagazine.com/wp

      1:16:07 PM

    • Ferdinando
      he changed in .user.ini max_input_vars from 1000 to 10000

      1:17:18 PM

    • Jason
      is he in there making changes now?

      1:17:49 PM

    • Ferdinando
      as it is not working he wants to know if this change works now or he has to wait for a server reboot

      1:18:25 PM

    • Ferdinando
      he made 2 days ago

      1:18:46 PM

    • Jason
      I disabled his .user.ini (it had way too much stuff in it) and made my own

      1:20:02 PM

    • Jason
      max_input_vars = 50000

      1:20:08 PM

    • Jason
      and it is reflecting in a phpinfo.php

      1:20:15 PM

    • Ferdinando
      ok

      1:20:39 PM

    • Jason
      and im unable to read much in his wp-admin

      1:21:30 PM

    • Jason
      to try and make a new microsite

      1:21:35 PM

    • Ferdinando
      ok, but do you think now it might work?

      1:22:07 PM

    • Jason
      I don't see any reason why it wouldn't and honestly, I don't think the input vars would have any impact on it either, but it might, which is why i added 5x more than what he had

      1:22:54 PM

    • Ferdinando
      the developpers of the wp template had said so to the customer

      1:23:33 PM

    • Jason
      ok

      1:23:36 PM

    • Jason
      then he has them set to 50,000 right now

      1:23:43 PM

    • Jason
      you can have him try if you like

      1:23:50 PM

    • Ferdinando
      ok, he is trying

      1:24:10 PM

    • Ferdinando
      is it possible to copy the same file .user.ini to a new directory for a new site?

      1:25:25 PM

    • Jason
      if it is in public_html it will cover all sites on here.

      1:25:37 PM

    • Ferdinando
      ok

      1:26:05 PM

    • Ferdinando
      he is still trying

      1:28:24 PM

    • Ferdinando
      when he tries to save he gets an error

      1:30:38 PM

    • Jason
      what is the error

      1:30:43 PM

    • Ferdinando
      he is saying that after these changes it is necessary to reboot the server

      1:31:19 PM

    • Jason
      it is not.

      1:31:21 PM

    • Jason
      i have confirmed it via phpinfo.php (he can also)

      1:31:31 PM

    • Jason
      If he feels that the server needs to be rebooted, he will need to move to a vps where he can control that.

      1:31:52 PM

    • Ferdinando
      Non Acceptable A appropriate representation of the requested resource /wp/wp-admin/options.php could not be found on this server

      1:34:55 PM

    • Ferdinando
      Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

      1:35:45 PM

    • Jason
      how can i duplicate?

      1:36:40 PM

    • Ferdinando
      sorry, I cannot understand

      1:37:17 PM

    • Jason
      how can I get the error message

      1:37:26 PM

    • Jason
      what steps can I take to see the error

      1:37:34 PM

    • Ferdinando
      I sent you it

      1:37:43 PM

    • Ferdinando
      Non Acceptable A appropriate representation of the requested resource /wp/wp-admin/options.php could not be found on this server
      1:34:55 PM
      Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

      1:38:04 PM

    • Jason
      Yes I see that

      1:38:06 PM

    • Jason
      but I want to actually GET the error message

      1:38:15 PM

    • Ferdinando
      you should go to the template options and in the control panel of the template Flavor you should choose a microsite "Motori" and "Confirm Taxonomies" for forcing the save

      1:41:36 PM

    • Jason
      Where is the confirm taxonomies button? I see save all changes

      1:43:03 PM

    • Ferdinando
      if you give me an email address I can send you a screenshot

      1:43:05 PM

    • Jason
      xxxxxxxxxx@godaddy.com

      1:43:19 PM

    • Jason
      ok, i just found it

      1:43:32 PM

    • Jason
      this is a theme issue

      1:43:36 PM

    • Ferdinando
      sent

      1:43:50 PM

    • Jason
      Yes, this is a theme issue

      1:44:38 PM

    • Ferdinando
      ok, thank you

      ok and now? i made a change max_input_vars to 50000 … but nothing.

      suggestion?? i'll give u user and pass so you can check the site … ?

  •  321
    Brian replied

    Are you sure the change is taking affect on your site? To check, add <?php phpinfo(); ?> at the very end of your footer.php file and then search for the max_input_vars entry and verify the value has been increased. Sometimes it's changed in the wrong place on the server, and this is a sure way to test to see if the change is actually taking affect.

  • Maximiliano replied

    hmhmhm i don t know if i understand but i have this: http://andcomagazine.com/phpinfo.php can u check plz

  •   Maximiliano replied privately
  •  321
    Brian replied

    I see a local value increased correctly, but the master value is still 1000. I'm wondering if this link is actually outside of your wp installation and not affecting it. Can you actually put the phpinfo() function at the bottom of the theme's footer.php file so I can see what the value is when I'm looking at a page that is actually part of your WordPress installation?

  • Maximiliano replied

    i'll send a private mess with details …

    PS: when i speak with go daddy support if i don't understand wring … they said that master value can be modify ….

    i'm sorry i'n not an php expert … i'm a graphic designer … :P

    so if u can help me … 

    but what about your demo flavour theme page???

  • Maximiliano replied

    hi there did u any news?

    thanks

  •  321
    Brian replied

    I didn't receive an email - not sure if you sent one - but you don't need to do that, just keep it here in this ticket and use a private response if you have sensitive information to share. Flavor on my demo site is running fine, I'm trying to help you isolate why it's not working for you.

  •   Maximiliano replied privately
  • Maximiliano replied

    a few moment ago i'll send you a private massage with log details …

  •  321
    Brian replied

    OK I was able to login and check and verify that you do have max_input_vars increased, so the issue must be coming from somewhere else. I was thinking it was possibly just an issue with it taking a long time since you have a lot of minisites which can require some server resources, but I let it sit for over a minute and it never loaded, so I'm wondering what PHP errors showed up in your error_log - there has to be some since it never loaded the theme options, I just want to know what they are.

  • Maximiliano replied

    ok thanks i'm here let me know more if we can solve that issue … because maybe some else made more mini site then 3 or 4 …. what do u think.

    see u

    --max

  •  321
    Brian replied

    Oh yes I've definitely seen more minisites than that, but every server environment is different. There isn't a hard and fast rule for number of minisites. Does it work if you remove any minisites? When you add them back, when exactly does it stop saving? You could try on a new fresh test WordPress installation if you want. Also maybe the local value doesn't matter and it's instead the master value that matters for max_input_vars, I"m not sure.

  • Screencredits replied

    Hi Max -

    Which GoDaddy web-hosting plan do you have?

    - Jason

  • Maximiliano replied

    hi jason, my plan on godaddy is deluxe …

    about your question …. the installation that u see now … is the third … :( (first in subdir sito, then site now wp subdir) … i tried to delete a mini site and create new one but nothing.

    for example now i have a problem with 2 last mini site "MOTORI" and " SHORT" … if i select some option, to test, Disable Editor Ratings (off), Disable User Ratings (off), Hide Editor Ratings (off), Hide User Ratings (off). then i click save changes â€¦ but nothing … 

    ….. :(

  • Maximiliano replied

    i tried now this thing …

    i created a taxonomy "scooter" so i forced to save using "confirm taxonomies" this is the result in image …. :(

  •  321
    Brian replied

    Wow, no idea what that's about - I do not recognize those errors. Definitely web host territory there - you should show that to them.

  • Maximiliano replied

    ok and about mini site did u have found some suggestion? 

  •  321
    Brian replied

    I think it's all caused by the same core server issues

  • Screencredits replied

    Hi Max -

    Could you be a little more specific with regard to your web-hosting plan?

    Are you using GoDaddy's newer Deluxe cPanel plan? Or their older non-cPanel Deluxe plan? Is it Windows or Linux based.

    I just tested Flavor on GoDaddy's non-cPanel Ultimate Linux Plan (no difference to Deluxe - server-wise - as far as I know). I installed a fresh copy of WP (3.9.1) and Flavor.

    I created 15 mini-sites. And the site is still working without issue. I also did not change the default max_input_vars setting of 1000.

    I have a feeling, the problem might be with your WP install itself.

    OR - the server that your site is hosted on could be timing out in the process of communicating with the site's database. I had that issue about a month ago. I solved the issue by switching to one of GoDaddy's new cPanel Plans.

    - Jason

  • Maximiliano replied

    hi jason,

    i use deluxe plan linux with new cPanel

    …. i write a private message …. 

    thanks

  •   Maximiliano replied privately
  •   Maximiliano replied privately